Wifi Attachment Manual
V1.5.3

Copyright 2010 – Reef Angel
All Rights Reserved

The product and the information contained herein are subject to change without notice.
This manual may not, in whole or in part, be reproduced or transmitted in any form either electronically or mechanically, including
photocopying and recording, without the express written consent of Reef Angel.

Wifi Attachment Unit
1.
2.
3.
4.
5.

Communication port
Green LED – TCP connection status
Blue LED – Wifi association status
Yellow LED – TX/RX data transfer
Red LED – General I/O

Condition

Blue

Yellow

Not Associated

RX/TX data
transfer

ON (Solid)
Fast Blink
Slow Blink
Off

Associated,
No Internet
Associated,
Internet Ok

Green
Connected over
TCP
No IP Address
IP Address OK

Getting Started
Before you start using your wifi attachment, you will need to set it up first. The attachment comes with some
default settings. It can be setup in either ad-hoc or infrastructure networks. For our purposes, we will set it up
for infrastructure mode. If you need any additional or more detailed information, please visit the wifi module
manufacturer’s website at: http://www.rovingnetworks.com/wifly-gsx.php

Setting up your Reef Angel Wifi Attachment using WPS Push-Button
WPS (Wifi Protected Setup) is a simple and secured way to connect to a device into an existing network.
If your router has this feature too, follow the simple steps to get connected.

1.
2.

Connect the USB-TTL cable in any available USB port in your computer
Connect the other end on the Reef Angel Wifi Attachment.

3.

Using a paper clip or a small pin, insert into the WPS Push Button orifice and press the button.

4.
5.

Push the WPS button on your router.
After a few seconds, you should have your wifi attachment blinking slow green and no blue. If you still have the blue
led blinking, the connection was not successful.

Setting up your Reef Angel Wifi Attachment using the Wifi Utility
Using the Wifi Utility application that was installed with your Reef Angel Installer, you will be able to easily configure your Reef
Angel Wifi Attachment.

1.

Connect the USB-TTL cable in any available USB port in your computer

2.

Connect the other end on the Reef Angel Wifi Attachment.

3.

Start the Wifi Utility application.

4.

Select a Serial Port.

5.
6.

Click the "Connect" Button.
Once connected, you will see the application log as shown:

7.
8.

Type the SSID of your wireless network.
Type the PassPhrase of your wireless network. The preferred and recommended security mode is WPA2-PSK with AES
encryption.

9.

Click the button "Setup Wifi Attachment"

10. Once the application finishes setting up your wifi attachment, you will see the application log as shown:

11. Please make note of the ip address. You will need it later. In this example, the IP address is 10.1.10.50 and the port is
2000.

12. Congratulations. Your Reef Angel Attachment is configured.

Setting up your Reef Angel Wifi attachment using your Reef Angel Controller
1.
2.
3.
4.
5.
6.
7.
8.

Start your Arduino software
Open the wifi setup code by going to menu File->Sketchbook->Example Codes and selecting WifiSetup
Modify the settings to match your own wifi authentication
Upload the code to your Reef Angel Controller
After uploading the code, disconnect the USB-TTL converter cable and connect your wifi attachment. For
more information on how to connect the wifi attachment, please refer to “Connecting your Reef Angel
Wifi attachment to the Head Unit” in this manual
Press the joystick button.
If the wifi attachment is able to connect successfully to your wifi network, it will present you with the IP
address that was assigned to it. This is the number you will need to use on any of the available apps.
You are now ready to start using your wifi attachment.

Manual Setup of your Reef Angel Wifi attachment
9.

Connect your USB-TTL converter cable to an available port of your computer

10. Download Tera Term software from http://www.rovingnetworks.com/resources/download/86/Teraterm
11. After installing Tera Term, start the application and you will be prompted with a new connection window.
Just click the Cancel button.

12. In the menu bar, go to Setup -> Serial port and the Serial port setup window will pop up.

13. Change the Port to the COM port you are using and click OK.
Note: this is the same COM port that you have selected on the Arduino IDE under Tools -> Serial Port

14. Connect the other end of the USB-TTL converter cable to the communication port of your Reef Angel wifi
attachment.

15. You will see the green and blue LEDs blinking and Tera Term will show the following screen:

16. We are now ready to start communication with the Reef Angel wifi attachment.

17. By default, the device will be in data mode. Type $$$ to enter into command mode. The device will
respond with CMD
Note: You won’t see when you type the $$$ and you have to make sure to type all three dollar signs
within 1 second.
18. Type set s p 0
The device will respond with AOK.
This will disable the authentication message that keeps showing every second.
19. Type set u b 57600
The device will respond with AOK.
This will set the serial baud rate to 57600bps.
20. Type save
The device will respond with AOK.
21. Type reboot
The device will respond with *reboot*.
The device will reboot and you won’t see the authentication message anymore.
22. Restart the Tera Term application.
23. We now need to change the baud rate on Tera Term, so when you are prompted to a new connection,
just click the Cancel button.
24. In the menu bar, go to Setup -> Serial port and the Serial port setup window will pop up.
25. Change the Port to the COM port you are using and Baud rate to 57600 and click OK.

26. Type $$$ to enter command mode again. The device will respond with CMD

27. To check the current wifi settings, type get w
The device will return with:

SSID=roving1
Chan=0
ExtAnt=0
Join=1
Auth=OPEN
Mask=0x1fff
Rate=12, 24 Mb
Linkmon=0
Passphrase=rubygirl
28. Type set c o 0
Sets the string that is sent to the local UART when the TCP port is opened. If no string is desired, use 0 as
the <string> parameter. Max string length is 32 characters. Default is *OPEN*
The device will respond with AOK.
29. Type set c r 0
Sets the string that is sent to the remote TCP client when the TCP port is opened. If no string is desired,
use 0 as the <string> parameter. Max string length is 32 characters. Default is *HELLO*
The device will respond with AOK.
30. Type set c c 0
sets the ASCI string that is sent to the local UART when the TCP port is closed. If no string is desired, use 0
as the <string> parameter. Max string length is 32 characters. Default is *CLOS*
The device will respond with AOK.
31. Type set c s 1024
Sets the flush size. An IP packet will be sent each time “value” bytes are received. Default is 64 bytes. You
should set this value to the largest possible setting to maximize TCP/IP performance. Maximum value =
1420 (at 9600) bytes.
32. You need to identify which type of wifi authentication you have.
The current release of Wifly firmware supports these security modes:
• WEP-128 (open mode only, NOT shared mode)
• WPA2-PSK (AES only)
• WPA1-PSK (TKIP only)
• WPA-PSK mixed mode (some APs, not all are supported)
33. Type set w a <value>
Sets the authentication mode.
Value
0
1
2
3
4

Authentication Mode
Open (Default)
WEP-128
WAP1
Mixed WAP1 & WAP2-PSK
WAP2-PSK

5
6

Not Used
Adhoc, Join any Adhoc network

The device will respond with AOK.
34. If you are using authentication mode 2,3 or 4 please go to step 19.
For authentication mode 1, type set w k <value>
Sets the 128 bit WEP key.
Key must be EXACTLY 13 bytes (26 ASCII chars). Data is expected in HEX format, “0x” should NOT be used
here. Example : “set w k 112233445566778899AABBCCDD”
Hex digits > 9 can be either upper or lower case.
The device only supports “open” key mode, 128 bit keys for WEP. WEP-128, shared mode is not
supported as it is known to be easily compromised and has been deprecated from the WiFi standards.
The device will respond with AOK.
35. For authentication mode 2,3 or 4, type set w p <string>
Sets the passphrase for WPA and WPA2 security modes. 1-64 chars.
The passphrase can be alpha and numeric, and is used along with the SSID to generate a unique 32 byte
Pre-shared key (PSK), which is then hashed into a 256 bit number. Changing either the SSID or this value
re-calculates and stores the PSK.
The device will respond with AOK.
36. Type set w s <string>
sets the wlan ssid to associate with. 1-32 chars.
NOTE: If the passphrase or ssid contain the SPACE ( ‘ ‘) characters, these can be entered using substitution
via the “$” character.
For example, if the ssid of the AP is “yellow brick road” You would enter “yellow$brick$road”
Using the get w command will properly display the value: SSID=yellow brick road.
37. Type save
The device will respond with AOK.
38. Type reboot
The device will respond with *reboot*.
The device will reboot and associate with the wifi network.
You will notice that if everything is OK and you have DHCP enabled in your router, the blue LED will turn
off.
39. Congratulations!! You have now setup your Reef Angel wifi attachment.
40. To check your wifi settings, follow steps 15-19.
41. Type get i
The device will return with something like this:
IF=UP
DHCP=ON
IP=192.168.9.20:2000
NM=255.255.255.0
GW=192.168.9.1
HOST=0.0.0.0:2000

PROTO=TCP,
MTU=1460
FLAGS=0x7
BACKUP=0.0.0.0
In this case, the IP address is 192.168.9.20 and the device is listening to port 2000.
Most routers have built in firewall that would block incoming data on port 2000. Make sure to allow
traffic or change the listening port. The IP address is the number you will need to use on any of the
available apps.
42. If you choose to change the local port, type set i l <num>
Sets the local port number, where num is the local port number. 80 is the most common open port on any
router.
43. Next time you connect to the device, you can choose to connect to it through the wifi network.
When you are prompted for a new connection, you can select TCP/IP.
On Host, type the ip address associated with the device, which in this case is 192.168.9.20
Select Telnet under the Service option and change the port to 2000 and click the Ok button.

Enabling connection timeout
This is an additional and optional step, although it is highly recommended.
This step will guarantee that any connection that stays idle for a determined amount of time is terminated. There
are many reasons why you should have a connection timeout, but the main reason is that the attachment can only
handle one connection at a time and if one connection is not closed properly, your wifi attachment would become
irresponsive because it would still be waiting for data in the opened connection that never got closed.
The drawback of having a connection timeout is that it is enabled even on command mode. This means that if you
are trying to change any settings on the wifi attachment, you cannot stop typing for more than the set number of
seconds or the connection would be terminated.
In order to enable a connection timeout, follow steps 15-19 of “Setting up your Reef Angel Wifi Attachment”
1.

Please type set c i 3
The device will respond with AOK.

2.

Type save
The device will respond with AOK.

3.

Type reboot
The device will respond with *reboot*.

Connecting your Reef Angel Wifi attachment to the Head Unit
1. Inspect the provided communication cable. It has 2 black connectors at the end. One is 6 pin and the
other is 8 pin.

2. Connect the 6 pin connector to the communication port of the Reef Angel wifi attachment.

3. Connect the 8 pin connector to the Serial TTL port of the Reef Angel Head Unit.

4. Your Reef Angel Controller is now connected to your wifi network.
5. Every time you need to load codes to your Reef Angel Controller, you will need to disconnect the wifi
attachment.

Testing the Reef Angel Wifi attachment
You will need to have setup your wifi attachment and also have the IP address it is using in your network. If
you don’t have done the setup nor have the IP address, please refer to “Getting Started” in this manual.

Uploading the test code
1.
2.
3.
4.

Start your Arduino software
Open the wifi test setup code by going to menu File->Sketchbook->Example Codes and selecting
WifiTestCode
Upload the code to your Reef Angel Controller.
After uploading the code, disconnect the USB-TTL converter cable and connect your wifi attachment. For
more information on how to connect the wifi attachment, please refer to “Connecting your Reef Angel
Wifi attachment to the Head Unit” in this manual

Connecting to your Reef Angel with your browser
1.

Start your favorite browser and type on the address bar: http://xxxx.xxxx.xxxx.xxxx:2000
Note: Replace the xxx.xxx.xxx.xxx with the IP address you collected previously when setting up the wifi
attachment.

2.

The controller will return with a default page “Reef Angel Controller Web Server”

3.

To use the built-in demo server, please go to http://xxx.xxx.xxx.xxx:2000/wifi

4.

The controller will then return with the demo web server where you can monitor the parameters and
override relays.

Restoring to Manufacturer’s Settings
If you need to restore your Reef Angel Wifi Attachment to manufacturer’s settings, there are 2 ways:

Soft Reset
1.

Follow the steps 15-19 of “Setting up your Reef Angel Wifi Attachment”.

2.

Type factory RESET
The device will respond with Set Factory Defaults

3.

Type reboot
The device will respond with *reboot*.

Hard Reset
1.

Disconnect your Reef Angel Wifi Attachment.

2.

Open the top cover of your Reef Angel Wifi Attachment and locate the jumper JP1.

3.

Place a jumper on JP1

4.

Connect your Reef Angel Wifi Attachment to your Reef Angel Controller.

5.

You will notice all 4 LEDs blinking at different rates.

6.

Take the jumper off and place it back in. Repeat this step 5 times.
Note, this step is sampled at 8Hz, so make sure that you wait at least 250ms between each transition.

7.

You will notice that the Yellow LED is off and the Red LED is on. This indicates a factory reset.

